Discussion:
Configuration Question regarding WSJT-X 1.4.0 on OS X 10.9
(too old to reply)
yahoo-FFn+FugcB13R7s880joybQ@public.gmane.org [linuxham]
2014-10-01 21:18:22 UTC
Permalink
Raw Message
I have a RigCat configuration question for OS X 10.9 while running WSJT-X 1.4.0


I have been trying to configure WSJT-X to communicate with my Kenwood TS-590S via USB. Currently, I am only able to get the TS-590S to transmit by using VOX. I would like to use RegCat to control the frequency and also transmit. I am trying to use the same device reference that I use on fldigi with RigCat (/dev/tty.SLAB_USBtoUART) but, with no success. (I edited the wsjtx.ini file to add the device.)


I'm sure it's something simple that I am missing in order to get WSJTX to call the RigCat routine for communicating with my TS-590S


Thanks,
Eric, W7CSD
Dave Wright hfradiopro-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org [linuxham]
2014-10-01 21:25:08 UTC
Permalink
Raw Message
WSJT-X doesn't use RigCAT; it uses Hamlib. Did you install hamlib according
to the instructions (README file) in the WJST-X download?

Have you activated Rig Control in the preferences for WJST-X, or by
manually editing the ini file to turn on Rig Control?

​Have you told WSJT-X (in the preferences) which PTT to use? I believe you
can use PTT method of CAT, as the 590s supports the CAT command for PTT, I
believe.

You're not trying to run Fldigi and WSJT-X at the same time, are you? For
that matter, WSJT-X and any other program with control over the rig (such
as a logbook program). Only one program at a time. ​


Dave Wright
K3DCW

www.machamradio.com

"Real radio bounces off the sky"
Post by yahoo-FFn+***@public.gmane.org [linuxham]
I have a RigCat configuration question for OS X 10.9 while running WSJT-X 1.4.0
I have been trying to configure WSJT-X to communicate with my Kenwood
TS-590S via USB. Currently, I am only able to get the TS-590S to transmit
by using VOX. I would like to use RegCat to control the frequency and also
transmit. I am trying to use the same device reference that I use on fldigi
with RigCat (/dev/tty.SLAB_USBtoUART) but, with no success. (I edited the
wsjtx.ini file to add the device.)
I'm sure it's something simple that I am missing in order to get WSJTX to
call the RigCat routine for communicating with my TS-590S
Thanks,
Eric, W7CSD
ki7mt ki7mt-/E1597aS9LQAvxtiuMwx3w@public.gmane.org [linuxham]
2014-10-01 23:00:38 UTC
Permalink
Raw Message
Hi Dave, Eric

The current beta version v1.4.0-rc2 does not use Hamlib from
repositories. I has a custom build of Hamlib3 (Static Libs) and
rigctld-wsjtx (shipped with the package). As such, you should not have
to install Hamlib in order to test WSJT-X v1.4.0 RC2.

As Dave stated, RigCat is a moot point, as WSJT-X does not use that
control method.

73's
Greg, KI7MT
Post by Dave Wright hfradiopro-***@public.gmane.org [linuxham]
WSJT-X doesn't use RigCAT; it uses Hamlib. Did you install hamlib
according to the instructions (README file) in the WJST-X download?
Have you activated Rig Control in the preferences for WJST-X, or by
manually editing the ini file to turn on Rig Control?
​Have you told WSJT-X (in the preferences) which PTT to use? I
believe you can use PTT method of CAT, as the 590s supports the CAT
command for PTT, I believe.
You're not trying to run Fldigi and WSJT-X at the same time, are you?
For that matter, WSJT-X and any other program with control over the
rig (such as a logbook program). Only one program at a time. ​
Dave Wright
K3DCW
www.machamradio.com <http://www.machamradio.com>
"Real radio bounces off the sky"
I have a RigCat configuration question for OS X 10.9 while running WSJT-X 1.4.0
I have been trying to configure WSJT-X to communicate with my
Kenwood TS-590S via USB. Currently, I am only able to get the
TS-590S to transmit by using VOX. I would like to use RegCat to
control the frequency and also transmit. I am trying to use the
same device reference that I use on fldigi with RigCat
(/dev/tty.SLAB_USBtoUART) but, with no success. (I edited the
wsjtx.ini file to add the device.)
I'm sure it's something simple that I am missing in order to get
WSJTX to call the RigCat routine for communicating with my TS-590S
Thanks,
Eric, W7CSD
Eric Struble yahoo-FFn+FugcB13R7s880joybQ@public.gmane.org [linuxham]
2014-10-02 19:07:12 UTC
Permalink
Raw Message
Hi Dave, Greg;

I guess it’s the case of RTFM. I apologize for mentioning RigCat in this thread. While skimming the instructions somewhere I either saw or thought I saw RigCat in the documentation or maybe I had RigCat on my mind since that is what fldigi uses.

Anyway I’ll see what I can do to get Hamlib to work.

On a side note I did run into a problem trying to install the latest version that is on the http://www.physics.princeton.edu/pulsar/K1JT/wsjtx.html website. Following the links, I downloaded the following file: • OSX 10.9: WSJT-X_rc1_10.9.dmg which downloaded just fine. I then opened up the .dmg file and thought it would be a good time to read the “ReadMe.txt file
 So far all OK. I then pulled the file: wsjtx-10.9-1.4.0-rc1.tar.gz out of the .dmg to the desktop, ran it to extract the .app. But, when I tried to run the wsjt application I keep getting the error: "Unable to create shared memory segment". I searched the HDD for any references to WSJT and removed any thing that was left from the earlier installation. I still get the same error. So, somehow I broke the installation and now I can’t go back to the previous version (same error).

What else should I be looking for that might be a remaining artifact that is causing a problem with the new installation?

Eric, W7CSD
Post by ki7mt ki7mt-/***@public.gmane.org [linuxham]
Hi Dave, Eric
The current beta version v1.4.0-rc2 does not use Hamlib from repositories. I has a custom build of Hamlib3 (Static Libs) and rigctld-wsjtx (shipped with the package). As such, you should not have to install Hamlib in order to test WSJT-X v1.4.0 RC2.
As Dave stated, RigCat is a moot point, as WSJT-X does not use that control method.
73's
Greg, KI7MT
WSJT-X doesn't use RigCAT; it uses Hamlib. Did you install hamlib according to the instructions (README file) in the WJST-X download?
Have you activated Rig Control in the preferences for WJST-X, or by manually editing the ini file to turn on Rig Control?
​Have you told WSJT-X (in the preferences) which PTT to use? I believe you can use PTT method of CAT, as the 590s supports the CAT command for PTT, I believe.
You're not trying to run Fldigi and WSJT-X at the same time, are you? For that matter, WSJT-X and any other program with control over the rig (such as a logbook program). Only one program at a time. ​
Dave Wright
K3DCW
www.machamradio.com
"Real radio bounces off the sky"
I have a RigCat configuration question for OS X 10.9 while running WSJT-X 1.4.0
I have been trying to configure WSJT-X to communicate with my Kenwood TS-590S via USB. Currently, I am only able to get the TS-590S to transmit by using VOX. I would like to use RegCat to control the frequency and also transmit. I am trying to use the same device reference that I use on fldigi with RigCat (/dev/tty.SLAB_USBtoUART) but, with no success. (I edited the wsjtx.ini file to add the device.)
I'm sure it's something simple that I am missing in order to get WSJTX to call the RigCat routine for communicating with my TS-590S
Thanks,
Eric, W7CSD
Dave Wright hfradiopro-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org [linuxham]
2014-10-02 19:43:05 UTC
Permalink
Raw Message
Read the README again, particularly the section about sysconf (or was is
sysctl.conf? I'm at work and can't recall) I think that is where your
error may be coming from. You may have to set that up again.

73

Dave
K3DCW

Dave Wright
K3DCW

www.machamradio.com

"Real radio bounces off the sky"
Post by Eric Struble yahoo-FFn+***@public.gmane.org [linuxham]
Hi Dave, Greg;
I guess it’s the case of RTFM. I apologize for mentioning RigCat in this
thread. While skimming the instructions somewhere I either saw or thought I
saw RigCat in the documentation or maybe I had RigCat on my mind since that
is what fldigi uses.
Anyway I’ll see what I can do to get Hamlib to work.
On a side note I did run into a problem trying to install the latest
version that is on the
http://www.physics.princeton.edu/pulsar/K1JT/wsjtx.html website.
Following the links, I downloaded the following file: • OSX
10.9: WSJT-X_rc1_10.9.dmg which downloaded just fine. I then opened up the
.dmg file and thought it would be a good time to read the “ReadMe.txt file

So far all OK. I then pulled the file: wsjtx-10.9-1.4.0-rc1.tar.gz out of
the .dmg to the desktop, ran it to extract the .app. But, when I tried to
run the wsjt application I keep getting the error: "Unable to create shared
memory segment". I searched the HDD for any references to WSJT and removed
any thing that was left from the earlier installation. I still get the same
error. So, somehow I broke the installation and now I can’t go back to the
previous version (same error).
What else should I be looking for that might be a remaining artifact that
is causing a problem with the new installation?
Eric, W7CSD
Hi Dave, Eric
The current beta version v1.4.0-rc2 does not use Hamlib from repositories.
I has a custom build of Hamlib3 (Static Libs) and rigctld-wsjtx (shipped
with the package). As such, you should not have to install Hamlib in order
to test WSJT-X v1.4.0 RC2.
As Dave stated, RigCat is a moot point, as WSJT-X does not use that control method.
73's
Greg, KI7MT
WSJT-X doesn't use RigCAT; it uses Hamlib. Did you install hamlib
according to the instructions (README file) in the WJST-X download?
Have you activated Rig Control in the preferences for WJST-X, or by
manually editing the ini file to turn on Rig Control?
​Have you told WSJT-X (in the preferences) which PTT to use? I believe
you can use PTT method of CAT, as the 590s supports the CAT command for
PTT, I believe.
You're not trying to run Fldigi and WSJT-X at the same time, are you? For
that matter, WSJT-X and any other program with control over the rig (such
as a logbook program). Only one program at a time. ​
Dave Wright
K3DCW
www.machamradio.com
"Real radio bounces off the sky"
Post by yahoo-FFn+***@public.gmane.org [linuxham]
I have a RigCat configuration question for OS X 10.9 while running WSJT-X 1.4.0
I have been trying to configure WSJT-X to communicate with my Kenwood
TS-590S via USB. Currently, I am only able to get the TS-590S to transmit
by using VOX. I would like to use RegCat to control the frequency and also
transmit. I am trying to use the same device reference that I use on fldigi
with RigCat (/dev/tty.SLAB_USBtoUART) but, with no success. (I edited the
wsjtx.ini file to add the device.)
I'm sure it's something simple that I am missing in order to get WSJTX to
call the RigCat routine for communicating with my TS-590S
Thanks,
Eric, W7CSD
KI7MT ki7mt-/E1597aS9LQAvxtiuMwx3w@public.gmane.org [linuxham]
2014-10-02 19:51:49 UTC
Permalink
Raw Message
Hi Erix,

You should send this to the wsjt-devel / wsjtgroup lists so Bill and
John can address it, as I've no idea on what would be causing the Shared
Memory issue.

wsjt-deval: wsjt-devel-5NWGOfrQmneRv+LV9MX5uv+2+***@public.gmane.org
wsjtgroup: wsjtgroup-***@public.gmane.org

Try and give them as much detail as you can on what transpired, and the
end results.

73's
Greg, KI7MT
Post by Eric Struble yahoo-FFn+***@public.gmane.org [linuxham]
Hi Dave, Greg;
I guess it’s the case of RTFM. I apologize for mentioning RigCat in this
thread. While skimming the instructions somewhere I either saw or
thought I saw RigCat in the documentation or maybe I had RigCat on my
mind since that is what fldigi uses.
Anyway I’ll see what I can do to get Hamlib to work.
On a side note I did run into a problem trying to install the latest
version that is on
the http://www.physics.princeton.edu/pulsar/K1JT/wsjtx.html website.
Following the links, I downloaded the following file: • OSX
10.9: WSJT-X_rc1_10.9.dmg which downloaded just fine. I then opened up
the .dmg file and thought it would be a good time to read the
wsjtx-10.9-1.4.0-rc1.tar.gz out of the .dmg to the desktop, ran it to
extract the .app. But, when I tried to run the wsjt application I keep
getting the error: "Unable to create shared memory segment". I searched
the HDD for any references to WSJT and removed any thing that was left
from the earlier installation. I still get the same error. So, somehow I
broke the installation and now I can’t go back to the previous version
(same error).
What else should I be looking for that might be a remaining artifact
that is causing a problem with the new installation?
Eric, W7CSD
Post by ki7mt ki7mt-/***@public.gmane.org [linuxham]
Hi Dave, Eric
The current beta version v1.4.0-rc2 does not use Hamlib from
repositories. I has a custom build of Hamlib3 (Static Libs) and
rigctld-wsjtx (shipped with the package). As such, you should not have
to install Hamlib in order to test WSJT-X v1.4.0 RC2.
As Dave stated, RigCat is a moot point, as WSJT-X does not use that control method.
73's
Greg, KI7MT
Post by Dave Wright hfradiopro-***@public.gmane.org [linuxham]
WSJT-X doesn't use RigCAT; it uses Hamlib. Did you install hamlib
according to the instructions (README file) in the WJST-X download?
Have you activated Rig Control in the preferences for WJST-X, or by
manually editing the ini file to turn on Rig Control?
​Have you told WSJT-X (in the preferences) which PTT to use? I
believe you can use PTT method of CAT, as the 590s supports the CAT
command for PTT, I believe.
You're not trying to run Fldigi and WSJT-X at the same time, are you?
For that matter, WSJT-X and any other program with control over the
rig (such as a logbook program). Only one program at a time. ​
Dave Wright
K3DCW
www.machamradio.com <http://www.machamradio.com/>
"Real radio bounces off the sky"
I have a RigCat configuration question for OS X 10.9 while running WSJT-X 1.4.0
I have been trying to configure WSJT-X to communicate with my
Kenwood TS-590S via USB. Currently, I am only able to get the
TS-590S to transmit by using VOX. I would like to use RegCat to
control the frequency and also transmit. I am trying to use the
same device reference that I use on fldigi with RigCat
(/dev/tty.SLAB_USBtoUART) but, with no success. (I edited the
wsjtx.ini file to add the device.)
I'm sure it's something simple that I am missing in order to get
WSJTX to call the RigCat routine for communicating with my TS-590S
Thanks,
Eric, W7CSD
--
73's
Greg, KI7MT


------------------------------------
Posted by: KI7MT <ki7mt-/***@public.gmane.org>
------------------------------------
Loading...